/ Zope / Apsis / Pound Mailing List / Archive / 2017 / 2017-02 / pound does not build against latest openssl

[ << ] [ >> ]

[ Page not displaying correctly / weirdfish+subs ... ] [ Use variables values / Narcis Garcia ... ]

pound does not build against latest openssl
Andreas Nyback <andreas(at)nyback.com>
2017-02-02 00:32:37 [ FULL ]
With openssl-1.1.0d compile fails

config.c:571:36: error: expected expression before 'TABNODE'
     if((res->sessions = LHM_lh_new(TABNODE, t)) == NULL)

With openssl-1.0.2k it compiles fine

found a log of the same problem at https://breakpoint.cc/openssl-1.1-rebuild-2016-08-26/failed/pound_2.7-1.2_amd64-2016-08-26T19%3A32%3A37Z

brgds
Andreas Nyback

MailBoxer